Resolved
Some HMRC Income Tax requests are failing
- Resolved The service has been normal for 30 minutes. Resolved.
- Monitoring Our checks show the service is back to normal. We are monitoring it before closing this incident.
- Investigating Some requests to HMRC's Income Tax service are failing or timing out. If a page does not load, please try again in a few minutes.