Investigating
HMRC is slow to confirm Corporation Tax filings
- Investigating Filings submitted through #GoFile are reaching HMRC, but HMRC is taking longer than usual to return its final result. Nothing is needed from you: your return is lodged with an HMRC timestamp when you submit, and we email you as soon as HMRC confirms it.